Thursday, December 01, 2005

TMobile (USA) Minutes Used version 0.4

I have updated the extension to support FireFox 1.5. You can get it from Mozilla Update

16 Comments:

Anonymous Anonymous said...

i have the 0.4 version with firefox 1.5 and i have a tmobile family plan. with 500 minutes available. i have 177 minutes used but the toobar show 0/500

12/04/2005 3:11 PM  
Anonymous Anonymous said...

Winston Huang:

Please e-mail me at:

MikeNet.Atmega@GMAIL.com

regarding your extension - I couldn't find your e-mail address.

Thanks!

12/06/2005 3:01 AM  
Anonymous K said...

I have the same problem as the person who previously posted. When I log into my billing details (I also have a family share plan), it shows I have 636 minutes left, but the extension still says 0/700. I'm not sure why it's updating.

12/09/2005 12:18 AM  
Blogger Winston Huang said...

the problem with 0 minute used is caused by a bug in TMobile's web site. it's explained here:

http://optimize-it.blogspot.com/2005/11/tmobile-usa-minutes-used-firefox.html

12/09/2005 4:47 PM  
Anonymous Anonymous said...

This is a great extension. I notice that, at work, it works fine for me (fast internet access there). However, at home I have a dial-up connection, and the status always seems to be “Loading TMobile minutes used ...”. I’m guessing that it’s timing out making its way through the TMobile site. Could you add an option to allow for a longer timeout or no timeout?

12/10/2005 6:09 PM  
Anonymous Anonymous said...

how bout a similiar extension for sprint?? :)

12/11/2005 4:36 PM  
Anonymous Anonymous said...

I'm using Firefox 1.5 and when I open a browser, the extension hangs with the message Loading TMobile Minutes used.... then when I hover over it, I get the message Failed to parse the minutes used. Is anyone else having this problem and does anyone know a fix?

12/14/2005 10:25 AM  
Anonymous Anonymous said...

I have discovered a new bug.

If a gateway proxy is used (when first going to a webpage, the proxy page appears, which I use a web form to login to the proxy).

Until I manually login to this web form, no port 80 communications will work, so the plugin displays "Loading TMobile minutes used..." and never changes.

In order for me to get the plugin to work, I must login to the gateway proxy, exit FireFox, and reload it, as I now have permission so the plugin can contact the TMobile site.

It sounds like the plugin needs improvements in re-trying a connection that doesn't fail, but does not return the proper data.

towens01@UnityHealth.org

12/14/2005 11:20 AM  
Blogger Winston Huang said...

the extension opens a new connection each time. so if your proxy setting is correct, it should find the tmobile web site correctly. maybe something else is wrong here. it could be the javascript inside firefox is not reloading the proxy setting unless you restart firefox.

12/14/2005 12:07 PM  
Anonymous Travis Owens said...

Winston Huang,

Please note the gateway I am working under is not like a standard proxy. I don't configure a browser to use the proxy, nor is it something that Windows automatically detects.

What is happening is that your plugin tries to contact TMobile, and it receives the login page for the gateway (which is not a 404, it's a web page). If I authorize the connection in another connection, any other connections (iow Windows) CANNOT refresh to get their requested page. If they refresh, they receive the same gateway login page (even though they are authorized). The other way to get these other connections is to go back and click a link again (or to hit OK on the login page).

So in order for your plugin to work under a gateway proxy, you're plugins needs to re-request the url, not refresh.

If you want to make that change in the code, I'm a willing guinea pig to test it out.

towens01@UnityHealth.org

12/14/2005 1:11 PM  
Anonymous Anonymous said...

Ever since i changed my plan this weekend the plugin does not work anymore... it only says "Loading TMobile minutes used" and never displays my minutes.

This is my new plan: "BEST VALUE - GET MORE 1500 PLUS". I have a blackberry with enterprise activation turned on.

Suggestions?

12/19/2005 8:54 AM  
Anonymous RCampanile@aol.com said...

Hello really enjoyed your blog/site, found it very interesting and will bookmark it for future use, Hey I have a site that has to do with cell phone and if your in the market for a new cell phone and want to get it FREE after rebates check out my site here http://www.majurl.com/y43 I also have several other products that will save you money. Well Thanks for your time and wish you a wonderful 2006 . Here is that link again cell phone

1/11/2006 10:26 PM  
Anonymous RCampanile@aol.com said...

Hello really enjoyed your blog/site, found it very interesting and will bookmark it for future use, Hey I have a site that has to do with cellular phone and if your in the market for a new cell phone and want to get it FREE after rebates check out my site here http://www.majurl.com/y43 I also have several other products that will save you money. Well Thanks for your time and wish you a wonderful 2006 . Here is that link again cellular phone

1/11/2006 11:27 PM  
Anonymous RCampanile@aol.com said...

Hello really enjoyed your blog/site, found it very interesting and will bookmark it for future use, Hey I have a site that has to do with cellular phone and if your in the market for a new cell phone and want to get it FREE after rebates check out my site here http://www.majurl.com/y43 I also have several other products that will save you money. Well Thanks for your time and wish you a wonderful 2006 . Here is that link again cellular phone

1/11/2006 11:49 PM  
Anonymous pjbckb@yahoo.com said...

I installed your new FireFox extension for Verizon Minutes Used. When I set the options and clicked OK, the following appeared:

"Alert. An unknown error has ocurred.
TypeError: Win.gVerizonMinutesUsed has no properties"

I have only one phone and entered the number.I am using FireFox 1.5 with WinXP.

1/17/2006 1:37 PM  
Anonymous Sarcasmo said...

Any plans to update this to be compatible with later versions of Firefox? I'm using 2.0.

6/20/2007 4:27 PM  

Post a Comment

<< Home